Bug #154

False Positive for Private Member Access in Friends

Added by Thomas Corbat about 3 years ago. Updated about 1 month ago.

Status:ResolvedStart date:11 Nov 2014
Priority:NormalDue date:
Assignee:Thomas Corbat% Done:

0%

Category:TDD
Target version:-

Description

Accessing private members from friends is marked as an error.
Accessed member variable is labeled as visibility problem for function.

History

#1 Updated by Martin Oberhuber about 1 month ago

I also ran into this problem, a test project is on https://bugs.eclipse.org/bugs/show_bug.cgi?id=525321

#2 Updated by Thomas Corbat about 1 month ago

Martin Oberhuber wrote:

I also ran into this problem, a test project is on https://bugs.eclipse.org/bugs/show_bug.cgi?id=525321

Thanks for the nudge, I'll have a look at it.

#3 Updated by Thomas Corbat about 1 month ago

  • Status changed from New to In Progress

I was able to reproduce the issue.
Now I need to figure out why the (CDT) binding representing class A does not contain class B as a friend when separated into two files.

#4 Updated by Thomas Corbat about 1 month ago

False positive caused by bug in CDT: https://bugs.eclipse.org/bugs/show_bug.cgi?id=525645

#5 Updated by Thomas Corbat about 1 month ago

  • Status changed from In Progress to Resolved

This should be fixed autmatically when updating to CDT 9.3.3 as the behavior had been caused by this bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=525645

Also available in: Atom PDF