Bug #163

CUTE Help does not appear in Oxygen.1 table of contents

Added by Martin Oberhuber 2 months ago. Updated about 1 month ago.

Status:ResolvedStart date:12 Sep 2017
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Steps to reproduce:
1. On Ubuntu 16.04.2, install Eclipse C/C++ Oxygen.1rc3 package
https://hudson.eclipse.org/packaging/job/oxygen.epp-tycho-build/lastSuccessfulBuild/artifact/org.eclipse.epp.packages/archive/20170907-1650_eclipse-cpp-oxygen-1-RC3-linux.gtk.x86_64.tar.gz
2. Launch Eclipse, Help > Install : http://www.cute-test.com/updatesite : CUTE plugin + GCov add-on , Restart
3. Help > Help Contents, search for CUTE

--> No help match is found, following error is printed in the error log.
--> Checking the cute.help plugin, it looks like the entire docs/ tree has not been packaged ?!?
--> ~/.eclipse/org.eclipse.platform_4.7.1_2098449814_linux_gtk_x86_64/plugins/ch.hsr.ifs.cute.help_5.2.0.201705021108

Error logged:

eclipse.buildId=4.7.1.M20170901-1220
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.cpp.product
Command-line arguments: -data file:/home/mober/eclipse-workspace/ -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.cpp.product -debug /home/mober/eclipse/eclipse-debug.options

org.eclipse.help
Error
Tue Sep 12 11:25:58 CEST 2017
Error reading help table of contents file /"ch.hsr.ifs.cute.help/docs/toc.xml" (skipping file)

java.io.FileNotFoundException
at org.eclipse.help.internal.toc.TocFileParser.parse(TocFileParser.java:44)
at org.eclipse.help.internal.toc.TocFileProvider.getTocContributions(TocFileProvider.java:45)

History

#1 Updated by Thomas Corbat about 1 month ago

  • Status changed from New to Resolved

Thanks a lot for the detailed analysis. Indeed the structure of the help contents had not been correct. The help plug-in does not seem to have been built properly. We fixed it. The development update site already contains the fix. It will be integrated in the next release.

Also available in: Atom PDF